tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 20364] New: - Jasper custom tag rtexprvalue="true" doesn't seem to be honored for xml attributes
Date Fri, 30 May 2003 17:35:46 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20364>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20364

Jasper custom tag rtexprvalue="true" doesn't seem to be honored for xml attributes

           Summary: Jasper custom tag rtexprvalue="true" doesn't seem to be
                    honored for xml attributes
           Product: Tomcat 4
           Version: 4.1.24
          Platform: PC
        OS/Version: Windows NT/2K
            Status: UNCONFIRMED
          Severity: Normal
          Priority: Other
         Component: Jasper
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: halesm@hotmail.com


I am using a struts html:link custom tag and the JSP expression is not
processed.  Example

<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
<%int id=0;%>
<html:link page="/x.do?id=<%=id%>">link</html:link>

produces : 

<a href="/webapp-name/x.do?id=<%=id%>">link</a>

It should produce : 

<a href="/webapp-name/x.do?id=0">link</a>

However, if I place a jsp expression in the body of the html:link tag, it is
evaluated.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message