tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14895] - ServletRequestListener not unregistered when reloading a Webapp Context
Date Fri, 09 May 2003 16:11:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14895>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14895

ServletRequestListener not unregistered when reloading a Webapp Context





------- Additional Comments From hoju@visi.com  2003-05-09 16:11 -------
Ok, I no longer see the originally described behavior with a 2003-05-07 build of
Tomcat5, but I do see another similar problem.

At the beginning of application startup, this line is logged...

2003-05-09 10:55:50 createObjectName with
StandardEngine[Catalina].StandardHost[localhost].StandardContext[/myapp]


However, the same thing is done at the end of shutdown.  At the next startup,
that same line is printed out again.  This results in two object of the myapp
context existing.  The context will not work after this.  I just get a 404,
application is not available.

Should this be reported as a new bug or should this bug be re-opened?  BTW, you
can reproduce this by installing/removing any webapp via the manager app.

Jake

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message