tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12643] - Undeploy any application fails (Undeploy an Existing Application in the Manager App fails)
Date Thu, 08 May 2003 20:05:29 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12643>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12643

Undeploy any application fails (Undeploy an Existing Application in the Manager App fails)





------- Additional Comments From smcrae@pharmanet.com  2003-05-08 20:05 -------
Upon further investigation I was able to fix this problem, though I believe it 
is only a workaround:

1. Updated JDK to JDK1.4.1_02 (from _01) - not related as after reinstalling 
Tomcat problem still appeared, I just wanted to include this step for 
completeness.

2. In server.xml changed unpackWARS from "true" to "false" - at first this 
didn't appear to correct the issue even after restarting Tomcat. Had to shut 
down Tomcat, manually remove context for my app from server.xml, remove webapps 
dir for application and remove application dir from localhost and remove app 
WAR file from manager directory. After restarting Tomcat everything works as 
expected.

FYI: I am using Win2k for OS.

I think that undeploy should support unpackWARS="true", but apparently doesn't 
right now. Being somewhat new to Tomcat, do most users run with 
unpackWARS="false" even though that is not default?

FWIW, I was also getting the same error through the manager interface before 
the changes above and now it works also.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message