tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <r...@apache.org>
Subject Re: Connector issues
Date Fri, 04 Apr 2003 16:47:12 GMT
Jeff Tulley wrote:
> I think I've got a fix for the connector thing, gotta still try it out
> to be sure.  I just thought that the mbeans-descriptors fix is "low
> hanging fruit".  IE, with just a simple little fix, every time somebody
> is forced to go back to the old connector for one reason or another,
> they won't immediately come back to the list with the complaint of "I'm
> getting the following exception".  

I had been in favor of making the exception look nicer (but got vetoed 
by Craig way back then).
OTOH, I am against adding the declaration in the descriptors, which 
would make it sound the thing is supported.

The AJP 1.3 connector is based on the code from the old HTTP/1.1 
connector, which likely had issues in its thread pool (in addition to 
being very wasteful GC wise). I strongly advise against using it.

> But if an upgrade to commons-modeler would also fix the problem without
> changing deprecated code, I'm all for doing that instead.
> 
> Let me go check out my code changes to CoyoteRequest, see how they
> work...

Remy


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message