tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18582] New: - "jk_endpoint.c (90)]: workerEnv.init() create slot epStat.0 failed" isapi_redirector2.dll v2.0.2
Date Tue, 01 Apr 2003 20:01:01 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18582>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18582

"jk_endpoint.c (90)]: workerEnv.init() create slot epStat.0 failed" isapi_redirector2.dll
v2.0.2 

           Summary: "jk_endpoint.c (90)]: workerEnv.init() create slot
                    epStat.0 failed" isapi_redirector2.dll v2.0.2
           Product: Tomcat 4
           Version: 4.1.18
          Platform: PC
               URL: http://localhost/examples
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Connector:Coyote JK 2
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: sideshowfry@yahoo.com


isapi_redirector2.dll v2.0.2 failed where v2.0.1 worked.

I couldn't get isapi_redirector2.dll v2.0.2 to work.
(http://localhost:8080/examples worked, http://localhost/examples didn't.)
After much fiddling around, I switched to v2.0.1, rebooted and it worked.
(net stop iisadmin didn't help - had to reboot).

I got various errors shown in event manager as I fiddled with things in
jk2.properties and workers2.properties. Once I figured that the dll was the
only thing that made the difference, I reduced the errors to just this:

Error: [jk_endpoint.c (90)]: workerEnv.init() create slot epStat.0 failed

(Also, Error: [jk_shm.c (333)]: shm.init(): No file, but I don't think that
matters.)


Other stuff someone might want to know:
IIS/PWS 4 from NT Option Pack, freshly installed
NT4 SP6a Workstation, freshly installed
Tomcat 4.1.18, freshly installed

default jk2.properties file with (seemingly) nothing in it except comments
workers2.properties file created (the default referred to in
documentation/howtos didn't exist) containing:

# Define the communication channel
[channel.socket:localhost:8009]
info=Ajp13 forwarding over socket
tomcatId=localhost:8009

# Map the Tomcat examples webapp to the Web server uri space
[uri:/examples/*]
info=Map the whole webapp

Registry entries created:
[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
Redirector\2.0]
"extensionUri"="/jakarta/isapi_redirector2.dll"
"serverRoot"="C:\\java\\jakarta-tomcat-4.1.18"
"logLevel"="INFO"
"workersFile"="C:\\java\\jakarta-tomcat-4.1.18\\conf\\workers2.properties"

I used the /examples context in my testing. I haven't changed any other
settings or added any content to Tomcat or IIS.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message