tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Kersten" <>
Subject problems with building mod_jk
Date Mon, 14 Apr 2003 13:06:27 GMT

    I've tried to build mod_jk statically into Apache 1.3 on a FreeBSD
4.7 machine, but it miserable fails. Then I tried to build a dynamic and it failed with the same error. I did manage to get
Tomcat 4.1 up and running perfectly and my Apache 1.3 also works just
fine (both compiled from source), and now I'm ready to make the
connection between these two with mod_jk. I've used the configure
options below. What's going wrong exactly, and how can I solve this

in the directory:

i ran:
./configure --with-apxs=/usr/local/apache/bin/apxs

i got:
Making all in common
Making all in apache-1.3
/usr/local/bin/libtool --mode=compile gcc -DUSE_APACHE_MD5 -I
../common -I /include -I
/include/ -I/usr/local/apache/include -funsigned-char -DUSE_EXPAT -I..
/lib/expat-lite -g -O2  -I../common -c  -o mod_jk.lo
rm -f .libs/mod_jk.lo
gcc -DUSE_APACHE_MD5 -I ../common -I /include -I
/include/ -I/usr/local/apache/include -funsigned-char -DUSE_EXPAT -I..
/lib/expat-lite -g -O2 -I../common -c  -fPIC -DPIC -o .libs/mod_jk.lo
gcc: No input files specified
*** Error code 1

Stop in
*** Error code 1

Stop in /tmp/jakarta-tomcat-connectors-jk-1.2.2-src/jk/native.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message