tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17608] New: - Jasper cannot compile JSP files which use JDK 1.4 asserts.
Date Mon, 03 Mar 2003 17:09:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17608>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17608

Jasper cannot compile JSP files which use JDK 1.4 asserts.

           Summary: Jasper cannot compile JSP files which use JDK 1.4
                    asserts.
           Product: Tomcat 4
           Version: 4.0.6 Final
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Jasper
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: spneville@hotmail.com


We have some unit tests for a tag library that we have written. One of the JSP 
files uses an assert statement. Jasper fails to compile the JSP because there 
is no way to pass the source 1.4 flag to it.

We are running in a 1.4 VM, so we would expect Jasper to be able to compile 
JSP files using the 1.4 compiler. We are aware of workarounds (and also of the 
strange use of asserts in a JSP). However, it still seems that Jasper should 
support this.

Here is part of the exception:

com.cysive.is.ServerException: org.apache.jasper.JasperException: Unable to 
compile class for JSPNote: sun.tools.javac.Main has been deprecated.

An error occurred between lines: 8 and 51 in the jsp file: /jsp/select-test.jsp

Generated servlet error:
C:\projects\InteractionServer\server\default\live\war\Jetty_0_0_0_0_6080__tagli
b
-test_webchannel\jsp\select_0002dtest$jsp.java:111: Class org.apache.jsp.assert
not found.
                  assert bean == favoriteGameSelections;
                  ^
An error occurred between lines: 8 and 51 in the jsp file: /jsp/select-test.jsp

Generated servlet error:
C:\projects\InteractionServer\server\default\live\war\Jetty_0_0_0_0_6080__tagli
b
-test_webchannel\jsp\select_0002dtest$jsp.java:111: Invalid declaration.
                  assert bean == favoriteGameSelections;
                              ^
2 errors, 1 warning

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message