tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: [PATCH] allow tomcat5 to compile/run with JDK1.3
Date Mon, 03 Feb 2003 15:32:56 GMT
Tim Funk wrote:

> After looking at the older revisions, I agree my patch was stupendously
> horrible :(
> 
> The patch now uses reflection to keep the current code equivalent for
> jdk14 and use the old way in case of a jdk1.3 jvm.
> 
> That being said - I would assume that the RMI issue your patch addressed
> would still be an issue in JDK1.3. Can you give me some insight on what
> it was? If possible I can attempt to make the appropriate fix.
> 
> I think commons-dbcp project do some wacky magic on java src files (
> poor man's equivalent of c directives for code include/exclude). Is that
> an alternative to move towards for situations like this? Or is having
> one and only one binary the a better goal? (So users don't need to
> choose a 1.3 and 1.4 binary)

Oh, NO. Please don't even think about it.... Commons-dbcp must do it because
it is impossible to write a JDBC driver that works and compiles in both 1.3
and 1.4. 

Reflection is fine - I would preffer using a jdkCompat-like trick and have
substitute code for 1.3, but I'm fine with reflection.

Costin




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message