tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <>
Subject Re: [PATCH] allow tomcat5 to compile/run with JDK1.3
Date Mon, 03 Feb 2003 19:12:45 GMT
To get functionality like jdkCompat (and looking at tomcat3), it looks 
like something similar to the following would need added to the existing 
   <exclude name="org/apache/catalina/util/compat/"
Where would jdkCompat live with respect to package name? Does it belong 
in catalina? (org.apache.catalina.util.compat.ClassXXX)

Are there any other methods (wishlist) which need to be here?

Or am I getting ahead of myself and should I be patient and wait for 
someone with better insight to do this instead?


Remy Maucherat wrote:
> Costin Manolache wrote:
>> Tim Funk wrote:
>> Oh, NO. Please don't even think about it.... Commons-dbcp must do it 
>> because
>> it is impossible to write a JDBC driver that works and compiles in 
>> both 1.3
>> and 1.4.
>> Reflection is fine - I would preffer using a jdkCompat-like trick and 
>> have
>> substitute code for 1.3, but I'm fine with reflection.
> Yes, I agree using a compat class is definitely much nicer :)
> Remy

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message