tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17223] New: - java.io.EOFexception in catalina and tomcat loosing session
Date Wed, 19 Feb 2003 21:54:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17223>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17223

java.io.EOFexception in catalina and tomcat loosing session

           Summary: java.io.EOFexception in catalina and tomcat loosing
                    session
           Product: Tomcat 4
           Version: 4.1.18
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: allforgals@yahoo.com


Hi,
I and many others here have had this problem for a while now. When tomcat is 
started it starts ok but after that it continuously keeps throwing the 
following exception.
Starting service Tomcat-Standalone
Apache Tomcat/4.1.18
Starting service Tomcat-Apache
Apache Tomcat/4.1.18
java.io.EOFException
        at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputSt
ream.java:2438)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1245)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:324)
        at org.apache.catalina.session.StandardSession.readObject(StandardSessio
n.java:1337)
        at org.apache.catalina.session.StandardSession.readObjectData(StandardSe
ssion.java:852)
        at org.apache.catalina.session.FileStore.load(FileStore.java:337)
        at org.apache.catalina.session.StoreBase.processExpires(StoreBase.java:3
07)
        at org.apache.catalina.session.StoreBase.run(StoreBase.java:368)
        at java.lang.Thread.run(Thread.java:536)

Although the initial work around for this was to reinstall tomcat but this 
problem surfaces after 2 or 3 days of reinstall. Although this did not stop us 
from devlopment but recently the application has started loosing session 
information as well, which is a big show stopper as every few minutes we have 
to restart the computer to fix the problem but it starts shortly after we start 
our testing. The same piece of code if run on another computer with identical 
setup the application seems to work fine. There seems to be a memory leak 
somewhere because of which tomcat looses the session info. If anyone can please 
guide me on how to solving this problem. Thanks in advance.

Rohit.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message