tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: Tomcat 5 target JDK1.4?
Date Wed, 22 Jan 2003 15:31:54 GMT
V. Cekvenich wrote:
> 
>> I'm very happy that Tomcat works well on 1.4, I can't however see any
>> reason to "requiring" 1.4, what are the benefits? Should we artificially
>> create obstacles for the sake of it?
>>
>> Martin
> 
> 
> Would you be "more" happier if JDK 1.4 made tomcat faster and more 
> stable and have less jars, relative to other containers?
> Nothing to lose people, and something to gain.
> 1.3 has a bad GC for one.

A lot to lose, little to gain. You can use JDK1.4 with tomcat5.0 ( or 
tomcat3.0 if you want ), and so get the stability and speed - without
removing the choice to use JDK1.3 or open source VMs for other people.

A lot of people preffer more jars ( they can choose to replace ) versus 
the bloated rt.jar. Jasper requires Xerces2.x.y - while JDK1.4
bundles crimson. Log4j is better for logging than what is bundled in 1.4.

Do you see many programs that work only on windowsXP, but not on 2000 or 
9x ? Are people writting many applications
that work only on MacOS X 1.4, but not on MacOS X 1.3 ( I have no idea
what's the real version number ) ? Most linux applications will work
even with 0.99 kernel ( after a recompilation maybe ).

What we lose is choice - and that's a _lot_. Choice to use an open 
source VM, choice on the OS/platforms we support ( think FreeBSD and 
Linux on Arm/Sparc/PPC ), etc.

> I think TC4 = JDK1.3, but TC5 = JDK1.4.

Let's close this discussion. This is a decision that tomcat committers 
can make. My vote will be -1.

Costin



--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message