tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15810] New: - URL decoded using UTF-8, but should be ISO-8859-1
Date Sun, 05 Jan 2003 22:06:29 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15810>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15810

URL decoded using UTF-8, but should be ISO-8859-1 

           Summary: URL decoded using UTF-8, but should be ISO-8859-1
           Product: Tomcat 4
           Version: 4.1.18
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Connector:Coyote HTTP/1.1
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: skoehler@upb.de


hi,

It seems that URLs are decoded using UTF-8. It might be Jasper problem. I don't
know yet.

If i try to query the URL
  http://server/djh.de/%C3%BCtest
i get a 404 error-page stat states that file .../%C3%BCtest cannot be found.
If i try to query the URL
  http://server/djh.de/%C3%BCtest.jsp
i get a 404 error-page that states that file .../ütest.jsp cannot be found.
%C3%BC is the UTF-8 Encoding of ü

So Tomcat seems to decode the URL using UTF-8 which might be wrong, because many
Browsers (taking Mozilla as the reference here) encode the URL ütest.jsp to
%FCtest.jsp which should be ü's ISO-8859-1 encoding.

i'm using tomcat 4.1.18 and used tomcat's built in HTTP-server.
i didn't test mod_jk yet.

Apache's WebServer does use ISO-8859-1 decoding as far as i can tell.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message