tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15672] - DBCP doesn't work on Tomcat 4.1.18 with Oracle JDBC driver
Date Fri, 03 Jan 2003 08:42:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15672>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15672

DBCP doesn't work on Tomcat 4.1.18 with Oracle JDBC driver





------- Additional Comments From a.battistini@regione.toscana.it  2003-01-03 08:42 -------
Hello!
I receive the same errore using Informix.
Trying to resolve the problems I've modified the classes BasicDataSource and 
BasicDataSourceFactory and I've seen a strange thing:
On startup, Tomcat creates a DataSource correctly according to server.xml.
When I execute the ctx.lookup()/getConnection() for my DS, I see 
BasicDataSourceFactory creates a new BasicDataSource that contains only 
description, scope and auth (according to my web.xml) while driverClassName, 
maxWait and the other params doesnt't exist. WHen I do ds.getConnection I 
receive the error:
java.sql.SQLException: Cannot load JDBC driver class 'null'
        at org.apache.commons.dbcp.BasicDataSource.createDataSource 
BasicDataSource.java:289)
        at org.apache.commons.dbcp.BasicDataSource.getConnection
(BasicDataSource.java:162)
This is "normal" because createDataSource is called on the patial empty 
DataSource (that doesn't contain driverClassName etc...)

I hope I give you some idea to solve the problem.

Bye

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message