tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andris Spruds" <Andris.Spr...@stud.lba.lv>
Subject Bug in IIS JK2 connector? Can't upload multipart-forms...
Date Wed, 11 Dec 2002 14:27:58 GMT
Hi all,

I'm having problems with JK2 connector and Microsoft IIS. I can't upload files, more precisely,
the servlet does not get correct mime stream. The data is sent all-right, but the last mime
boundary usually is not there. Needless to say that the same servlet works fine with mod_jk2
and Apache, I have also succesfully tried it with IIS and Resin together with Caucho IIS connector
-  so I guess there is a bug in isapi_redirector.dll. HOWEVER, this only happens with big
form uploads, it works fine if I try to upload 16KB file, but fails when the file size exceeds
some 50-60KB.

The details follows:
I'm using Windows 2000 with SP3
I tried it with the latest Tomcat (4.1.12) and latest precompiled isapi_redirector2.dll
I stole MimeStream.java from Apache Turbine 2.2 project, but it works fine in other cases,
so I guess it can't be the cause of my problems.

I would be grateful if someone could give a hint on what can I do to solve it. Any ideas would
be more than welcome!

Thank you,
Andris Spruds

P.S.
This message goes to the dev list cause I feel there aren't very many users familiar with
JK2. Sorry if the user list would be better. Hope you don't mind.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message