tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15239] New: - Creating new <resource-link> uses TYPE attribute value for NAME attribute
Date Tue, 10 Dec 2002 16:14:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15239>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=15239

Creating new <resource-link> uses TYPE attribute value for NAME attribute

           Summary: Creating new <resource-link> uses TYPE attribute value
                    for NAME attribute
           Product: Tomcat 4
           Version: 4.1.16
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Webapps:Administration
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: rory.douglas@na.sunchem.com


When creating a new ResourceLink to a global DataSource, the Admin webapp 
creates the resource link using the value specified for TYPE for both TYPE and 
NAME attributes of the newly created element.

Thus creating one link to a DataSource "JDBC/Bob" with name "MyLinkToBob" 
creates an element:

<ResourceLink global="JDBC/Bob" name="javax.sql.DataSource" 
type="javax.sql.DataSource"/>

The name "MyLinkToBob" is lost.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message