tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14994] New: - https coyote connector leaving sockets in CLOSE_WAIT
Date Mon, 02 Dec 2002 14:34:35 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14994>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14994

https coyote connector leaving sockets in CLOSE_WAIT

           Summary: https coyote connector leaving sockets in CLOSE_WAIT
           Product: Tomcat 4
           Version: 4.1.12
          Platform: Other
        OS/Version: HP-UX
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Connector:Coyote HTTP/1.1
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: mtraum@cirnetwork.org


Sockets are being left in the CLOSE_WAIT state. Over the period of a couple of 
days, 11 (on a very low load machine) will be left hanging, which reaches 
my "acceptCount" setting and no more connections will be accepted.

I also have 11 "Broken pipe" IOExceptions, as described in bugzilla bug 4663, 
which I would assume is the root cause.

I don't know what else I can do to diagnose this. It is obviously a critical 
issue, as I can bump up "acceptCount", but sooner or later connections will not 
be accepted.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message