tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Hunter" <>
Subject Tomcat 4.1.12 root context index.jsp "bug"
Date Tue, 05 Nov 2002 15:32:50 GMT
I have posted this in several different ways on the user list and had
virtually no responses, and I believe it's a real live bug, so I'll post it
here and then prepare to duck flames...

Running Tomcat 4.1.12 with Sun JDK 1.4.1 on Win2K, if I change the root
context to point someplace other than webapps/ROOT, I still get the default
index.jsp if I request http://localhost:8080/index.jsp -- if that sounds
sketchy and weird, get a load of this:

I have also zipped up (removed the files from) webapps/ROOT completely
(actually, webapps is completely empty), cleared my browser cache, etc. etc.
and I still get the default index.jsp, but without the graphics (remember,
the files are not anywhere on my drive).

Further, I can successfully request any files OTHER than index.jsp (e.g.
main.jsp, logon.jsp, etc. etc.) from the directory containing the new root

Weird, eh?

Is there a newer build I should try?  I didn't see anything beyond 4.1.12

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message