tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: [5.0] [VOTE] Removal of the LE distribution
Date Fri, 04 Oct 2002 06:02:00 GMT
To clarify - my main concern is the second part of
'write once, run everywhere'. Right now JDK1.4 is just not
'everywhere', and I don't think any cool feature would 
justify sacrificing this. 

At this moment the 'everywhere' is defined ( at least IMO ) by
the free VMs ( kaffe, GCJ, etc ) - just look at the list of supported
platforms and OSes. 

So I'll be -1 on requiring JDK1.4 for container and connector -
if JSP2.0 requires 1.4, then we'll have to require it too for
the distribution, but it should still be possible to remove jsp
and run java web applications based on less requiring technologies.

I'm all for using JDK1.4 features like NIO or prefs - but that should
be done in a modular way that allows the system to work for most
users and platforms. 

I periodically test the compilation using GCJ - and so far we are ok
( except jasper, which can't be compiled - at least last time I tried -
due to inner classes and bugs in gcj ). 

For example - is JDK1.4 available for BSD or Sparc/Linux or Arm/Linux ? 
I think BSD and linux are fine operating systems and Tomcat should run
on them.

Costin


Remy Maucherat wrote:

> Costin Manolache wrote:
>> Remy Maucherat wrote:
>> 
>> 
>>>Hi all,
>>>
>>>Before starting to release 5.0.x milestones, I would like to propose
>>>having only one distribution for Tomcat 5.0.x, and standardize on what
>>>the LE distribution contains (so well, it's more the other distribution
>>>which gets removed).
>>>
>>>It has some advantages:
>>>- it is slightly smaller (less these days now that the XML parser has to
>>>be shipped again with Tomcat)
>>>- runs as-is on JDK 1.3 (because of the Xerces inclusion)
>>>- 99% Apache or Apache-style licence (the JDBC 2 standard extension is
>>>needed for JDK 1.3 DataSource support :-()
>>>- less user confusion
>>>
>>>The main "problem" is that the user will need additional downloads for
>>>some of the more advanced features, and the package will also not run on
>>>JDK 1.2 as is (but from what I've seen, JDK 1.2 compatibility may not be
>>>a priority for developers).
>>>
>>><ballot>
>>>+1 [X] Yes, remove the LE distribution
>>>-1 [ ] No, keep both distributions
>>></ballot>
>> 
>> 
>> What would it take to be 100% Apache-style licence ? Can we do some
>> introspection tricks or conditional compilation to solve this ?
> 
> I can remove the JDBC SE JAR, but then the JDBC connection pooling
> features won't work right out of the box on JDK 1.3 (assuming it is
> possible to run JDK 1.3 with TC 5).
> 
> A great blinking warning should be added to the download page and the
> release notes if we do that.
> 
> If somehow the Catalina (with JSP 2 support) adapter requires JDK 1.4,
> then JDBC SE can be removed.
> 
> Remy

-- 
Costin



--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message