tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brzezinski, Paul J" <paul.brzezin...@eds.com>
Subject List Archive: Follow-up - jk2 jni doesn't work
Date Thu, 10 Oct 2002 16:25:04 GMT
Jean-Frederic, Bill, Mladen Turk, List,

I found this in the archive -- was this resolved?  The code snippet

OPT=-Djava.class.path=${TOMCAT_HOME}\bin\tomcat-jni.jar;${TOMCAT_HOME}\serve
r\lib\commons-logging.jar

What file did this get added to?  I'm having *THIS* exact problem -- and
haven't been able to resolve it, I've built the connectors and
jakarta-tomcat-4.1.12 from src with no errors/problems but can't get the APR
to init because of the java.lang.NoClassDefFoundError in AprImpl.java.

I would like to get this working -- work-around is what I'm looking for,
please help.

Paul

>From the archive:

Re: [BUG] jk2 jni doesn't work

----------------------------------------------------------------------------
----

From: jean-frederic clere 
Subject: Re: [BUG] jk2 jni doesn't work 
Date: Wed, 18 Sep 2002 23:41:39 -0700 

----------------------------------------------------------------------------
----

Mladen Turk wrote:
> This is the classloader problem.
> 
> Think that Bill Baker is solving this, but until then add the
> commons-logging.jar to the loaded classes when started inprocess:
> 
> OPT=-Djava.class.path=${TOMCAT_HOME}\bin\tomcat-jni.jar;${TOMCAT_HOME}\s
> erver\lib\commons-logging.jar

I do not like this work-around: we will have end with a huge classpath.

> 
> Adding commons-logging to the classpath solves the JNI problem.
> 
> Bill, when can ve expect this will get solved?
> 
> 
> 
> 
>>java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
>>      at org.apache.jk.apr.AprImpl.<clinit>(AprImpl.java:348)
>>java.lang.NoClassDefFoundError
>>
>>
> 
> 
> MT.
> 
> 



--
mailto:Paul.Brzezinski@EDS.com
Enterprise Distributed Capabilities
EDS Corporation
248-265-8283


Mime
View raw message