tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Gomez <hgo...@apache.org>
Subject Re: [JK2] RedHat 8.0 JNI totaly bogus
Date Thu, 24 Oct 2002 08:15:44 GMT
Mladen Turk wrote:
> Hi,
> 
> Using JNI on RH8 using either original 2.0.40, Henri's 2.0.43-1.7.2 or
> build from sources (either prefork or worker).
> Even tried 2.0.1 rpm, but on all config when trying to use the [vm:] I'm
> having constant child_init, with cpu at 99%.
> ErrorLog is growing and seems that entire thing faults at vm_init
> (vm_default at 445 is the last thing logged).
> Nothing is passed after the loading of jvm, like the child process
> exits, but pool cleanup doesn't report that.
> After stopping httpd, a few childs are reported as 'still did not exit'.
> 
> I've put some extra ap_logs and the child pids are growing even when set
> StartServers to 1.
> The Java is 1.4.0_01 
> 
> Any clues?

I didn't tried RH 8.0 yet, but the experience I've got from RH 7.2 with
JNI make me some serious headaches.

Before launching Apache 2.0 you need :

1) set the LD_LIBRARY_PATH

export LD_LIBRARY_PATH=$jre/bin:$jre/bin/classic:$LD_LIBRARY_PATH

2) make JDK use the non floating stacks

export LD_ASSUME_KERNEL=2.2.5

Also I've got mixed success with IBM SDK 1.3.1 or Sun SDK 1.3.1, and
recommand you to test both of them.

I can make some tests under RH 7.2, just send me your config files...





--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message