tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Francois Arcand <jfarc...@apache.org>
Subject Re: [5.0] [VOTE] Removal of the LE distribution
Date Fri, 04 Oct 2002 13:39:51 GMT


Bill Barker wrote:

>----- Original Message -----
>From: "Remy Maucherat" <remm@apache.org>
>To: "Tomcat Developers List" <tomcat-dev@jakarta.apache.org>
>Sent: Thursday, October 03, 2002 7:50 PM
>Subject: Re: [5.0] [VOTE] Removal of the LE distribution
>
>
>  
>
>>Costin Manolache wrote:
>>    
>>
>>>Remy Maucherat wrote:
>>>
>>>
>>>      
>>>
>>>>Hi all,
>>>>
>>>>Before starting to release 5.0.x milestones, I would like to propose
>>>>having only one distribution for Tomcat 5.0.x, and standardize on what
>>>>the LE distribution contains (so well, it's more the other distribution
>>>>which gets removed).
>>>>
>>>>It has some advantages:
>>>>- it is slightly smaller (less these days now that the XML parser has to
>>>>be shipped again with Tomcat)
>>>>- runs as-is on JDK 1.3 (because of the Xerces inclusion)
>>>>- 99% Apache or Apache-style licence (the JDBC 2 standard extension is
>>>>needed for JDK 1.3 DataSource support :-()
>>>>- less user confusion
>>>>
>>>>The main "problem" is that the user will need additional downloads for
>>>>some of the more advanced features, and the package will also not run on
>>>>JDK 1.2 as is (but from what I've seen, JDK 1.2 compatibility may not be
>>>>a priority for developers).
>>>>
>>>><ballot>
>>>>+1 [X] Yes, remove the LE distribution
>>>>-1 [ ] No, keep both distributions
>>>></ballot>
>>>>        
>>>>
>>>What would it take to be 100% Apache-style licence ? Can we do some
>>>introspection tricks or conditional compilation to solve this ?
>>>      
>>>
>>I can remove the JDBC SE JAR, but then the JDBC connection pooling
>>features won't work right out of the box on JDK 1.3 (assuming it is
>>possible to run JDK 1.3 with TC 5).
>>
>>A great blinking warning should be added to the download page and the
>>release notes if we do that.
>>
>>If somehow the Catalina (with JSP 2 support) adapter requires JDK 1.4,
>>then JDBC SE can be removed.
>>    
>>
>
>Well, it seems that this has already been done without a [VOTE].  After a
>long time away from 5.0, I attempted to build it, only to discover that it
>can't be built any more.  As a result, I'm now (belatedly) posting my -1 to
>R1.2 of o.a.c.core.StandardWrapper.java. and R1.1 of o.a.c.u.SecurityUtil.
>Please change to a version that compiles under 1.2 at least until there is a
>[VOTE] to change the target version.  AFAIK, the target version is still the
>same as 4.x (e.g. 1.2).
>
I'm confuse. The Tomcat 4.0-4.1 documentatopm requires JDK 1.3 for 
compilling the source code:

" This subproject contains the source code Tomcat 4.0, a server that implements
the Servlet 2.3 and JSP 1.2 Specifications from Java Software.  In order to
build a binary distribution version of the container from a source
distribution, you must have a Java Development Kit (JDK) for version 1.3 (or
later) downloaded and installed (version 1.3.1 recommended), and do the
following:"

Tomcat should run on 1.2, but should it compile?

-- Jeanfrancois




>
>  
>
>>Remy
>>
>>
>>--
>>To unsubscribe, e-mail:
>>    
>>
><mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
>  
>
>>For additional commands, e-mail:
>>    
>>
><mailto:tomcat-dev-help@jakarta.apache.org>
>  
>
>
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>
>
>
>  
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message