tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From peter lin <peter....@labs.gte.com>
Subject Re: [Possible bug with jspc]
Date Wed, 02 Oct 2002 15:38:56 GMT

Here is a bit more information. I took a look at the jar files for jsp
1.1 tags and they include a taglib.tld file in meta-inf/.  Once I remove
that, it compiles the pages fine.  It looks like there's a conflict in
either jasper compiler or jspc that is unable to resolve which .tld file
to use.

peter lin wrote:
> 
> I spent the last two days trying to use JspC to compile an entire webapp
> and came across a problem. I'm not sure if this is a bug or not, but I
> can reproduce it every time.  I'm still trying to track down the cause,
> but I thought I'd post a question and maybe some one with more knowledge
> can point me in the right direction.
> 
> I am using the following command to run jspc
> 
> C:\tomcat\bin>jspc -d ..\work\Standalone\localhost\_ -uribase
> c:/myapp/web -webapp c:/myapp/web
> 
> in one of included files I define all the taglibs i use. right now I am
> using taglibs from the Jakarta. If I use the string tag, it causes JspC
> to die with NPE. If I remove the <%@ taglib %> for string tag, jspc
> works fine.  the main difference between JSTL and string tag is JSTL is
> 1.2 and string tag is 1.1.
> 
> the page works just fine if I load it in the browser, but for some
> reason, JspC doesn't like 1.1 taglibs.
> 
> can anyone provide any insight?
> 
> peter lin
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message