tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: jk 1.2.0 error reported on tomcat-user
Date Wed, 02 Oct 2002 07:15:31 GMT
Henri Gomez wrote:
> Someone has an idea of what could be the problem with ap_ctx-get ?
> 
> It seems the user make use of ApacheToolbox.
> 
> -----
> 
> This may add some info: I compiled Apache with ApacheToolbox. The
> modules are static but it has DSO support in it. Then again, I would
> expect an error much earlier in the load process then an undefined
> symbol.
> 
> 
> -----
> 
> 
> I downloaded the binary of mod_jk.so from Jakarta's downloads in
> /builds/jakarta-tomcat-connectors/jk/release/v1.2.0/bin/linux/i386. I am
> running Apache 1.3.26 with Tomcat 4.05 on Red Hat Linux release 7.1
> (Seawolf). The binary is compiled for 7.2, however. That may explain the
> following error when trying to start Apache:
> 
> 
> [root@dev bin]# ./apachectl configtest
> Syntax error on line 208 of /usr/local/apache-new/conf/httpd.conf:
> Cannot load /usr/local/apache-new/libexec/mod_jk.so into server: 
> /usr/local/apache-new/libexec/mod_jk.so: undefined symbol: ap_ctx_get
> 
> Any ideas? Do I need to upgrade gcc, possibly? What do the binaries rely 
> upon?

Sound eapi/noeapi problems.

> 
> Thanks in advance,
> 
> Ben Ricker
> 




--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message