tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14118] - JVM 1.4 dies when run as an NT service
Date Thu, 31 Oct 2002 09:51:48 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14118>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14118

JVM 1.4 dies when run as an NT service





------- Additional Comments From bloch@laszlosystems.com  2002-10-31 09:51 -------
It would help me a lot if you could describe accurately the difference
between the way the tomcat 4.1 NT service invokes the JVM and
the way the startup scripts do.  Assume default invocations.  I want
to eventually pass some gc debugging params to the jvm.

I'm attempting to install the NT service by hand using javaservice.exe
(which I nabbed from the javaservice website itself; latest bits) 
and when I use (from cygwin)

% JavaService.exe -install "Apache Tomcat 4.1x" \
          $JAVA_HOME\\jre\\bin\\server\\jvm.dll \
         -Djava.class.path="$TOMCAT_HOME\\bin\\bootstrap.jar" \
         -Dcatalina.home="$TOMCAT_HOME" \
         -Djava.endorsed.dirs="$TOMCAT_HOME\\common\\endorsed" \
         -start org.apache.catalina.startup.BootstrapService \
         -params start \
         -stop org.apache.catalina.startup.BootstrapService \
         -params stop \  
         -out "$TOMCAT_HOME\\logs\\stdout2.log" \
         -err "$TOMCAT_HOME\\logs\\stderr2.log"

$TOMCAT_HOME is C:\Tomcat4.1 where I've installed tomcat and
$JAVA_HOME is C:\j2sdk1.4.0_02 .

I get the following in stderr2.log

Created catalinaLoader in: C:\WINNT\system32\server\lib
java.lang.ClassNotFoundException: org.apache.catalina.startup.CatalinaService
        at org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClas
sLoader.java:992)
        at org.apache.catalina.loader.StandardClassLoader.loadClass(StandardClas
sLoader.java:857)
        at org.apache.catalina.startup.BootstrapService.init(BootstrapService.ja
va:198)
        at org.apache.catalina.startup.BootstrapService.main(BootstrapService.ja
va:297)
java.lang.NullPointerException
        at org.apache.catalina.startup.BootstrapService.stop(BootstrapService.ja
va:259)
        at org.apache.catalina.startup.BootstrapService.main(BootstrapService.ja
va:309)

I didn't see this class in the bootstrap.jar and I'm wondering how it's 
spose to be found.

Thanks!
-Eric

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message