tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: [5.0] [VOTE] Removal of the LE distribution
Date Thu, 03 Oct 2002 19:53:00 GMT

----- Original Message -----
From: "Costin Manolache" <cmanolache@yahoo.com>
To: <tomcat-dev@jakarta.apache.org>
Sent: Thursday, October 03, 2002 11:30 AM
Subject: RE: [5.0] [VOTE] Removal of the LE distribution


> iasandcb wrote:
>
> > First all, I vote
> > <ballot>
> > +1 [ ] Yes, remove the LE distribution
> > -1 [ ] No, keep both distributions
> > </ballot>
> >
> > Next, I'd like to make this clear: Tomcat 5 is based on JSP 2.0 spec,
> > which requires J2SE 1.4. Therefore Tomcat 5 also can't run without J2SE
> > 1.4 ideally. However, I found that the new catalina engine and jasper 2
> > compiler for Tomcat 5 don't mandate so.
> > Is J2SE 1.4(or later) necessary for Tomcat 5? Or does Tomcat 5 support
> > J2SE 1.3(or earlier) for backward compatibitity with disabled JSP 2
> > feature?
> > My opinion on this issue is that Tomcat 5 should have J2SE 1.4 in
> > compliance with JSP 2.0 spec basically.
>
> What ???
>
> Where did you find this info ? I read the JSP2.0 draft and didn't
> find such thing. It would be just stupid - I don't know any
> other spec to require more than Java2 (i.e. JDK1.2+).
>
> If the final spec is aproved and includes JDK1.4 requirements - then
there's
> nothing we can do, we'll have to stop supporting 1.3 in the official
tomcat
> distibution. But given that now the 2 specs are distinct - and
> some people use only the servlet spec, I think the servlet engine and
> connectors should remain JDK1.2+.

I can't find this either.  And if true, would create big problems in that
the 2.4 servlet spec mandates only Java 2.
<spec-quote spec="servlet" version="2.4" section="1.2">
J2SE 1.2 is the minimum version of the underlying Java platform with which
servlet containers must be built.
</spec-quote>

The only mention of 1.4 I see in either spec is that any 1.4 J2EE
implementation must implement Servlet-2.4 & JSP-2.0.  Please give a cite for
the 1.4 requirement.

>
> Costin
>
>
> >
> > IAS
> >
> > -----Original Message-----
> > From: Remy Maucherat [mailto:remm@apache.org]
> > Sent: Friday, October 04, 2002 2:24 AM
> > To: Tomcat Developers List
> > Subject: [5.0] [VOTE] Removal of the LE distribution
> >
> >
> > Hi all,
> >
> > Before starting to release 5.0.x milestones, I would like to propose
> > having only one distribution for Tomcat 5.0.x, and standardize on what
> > the LE distribution contains (so well, it's more the other distribution
> > which gets removed).
> >
> > It has some advantages:
> > - it is slightly smaller (less these days now that the XML parser has to
> >
> > be shipped again with Tomcat)
> > - runs as-is on JDK 1.3 (because of the Xerces inclusion)
> > - 99% Apache or Apache-style licence (the JDBC 2 standard extension is
> > needed for JDK 1.3 DataSource support :-()
> > - less user confusion
> >
> > The main "problem" is that the user will need additional downloads for
> > some of the more advanced features, and the package will also not run on
> >
> > JDK 1.2 as is (but from what I've seen, JDK 1.2 compatibility may not be
> >
> > a priority for developers).
> >
> > <ballot>
> > +1 [ ] Yes, remove the LE distribution
> > -1 [ ] No, keep both distributions
> > </ballot>
> >
> > Remy
> >
> >
> > --
> > To unsubscribe, e-mail:
> > <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
> > <mailto:tomcat-dev-help@jakarta.apache.org>
>
> --
> Costin
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message