tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Trollinger" <jaka...@trollingers.com>
Subject RE: JSP Compilation Issues (Multiple Domains)
Date Tue, 01 Oct 2002 11:56:25 GMT
Can we get the sync changes in the 4.1.x releases as we also have
problems with this and currently maintain our own jasper code base with
the sync code in it.

> -----Original Message-----
> From: Kin-Man Chung [mailto:Kin-Man.Chung@Eng.Sun.COM] 
> Sent: Monday, September 30, 2002 9:47 PM
> To: tomcat-dev@jakarta.apache.org
> Subject: Re: JSP Compilation Issues (Multiple Domains)
> 
> 
> If you are using JDK javac for compiling the servlet 
> generated by the JSP compiler, then you probably ran into the 
> problem that the javac not being thread-safe.
> 
> In Tomcat 5 the javac compilation is synchronized, so that 
> the compilation is serialized.  Guess that fix is not ported 
> to 4.1.5.  :-(
> 
> I always assume that JSP pages would be deployed precompiled, 
> and simultaneous compilation under development mode is rare.  
> Maybe my assumption is wrong?
> 
> 
> > Date: Mon, 30 Sep 2002 18:30:48 -0700
> > From: Joseph Kiok <joseph@ggold.net>
> > Subject: JSP Compilation Issues (Multiple Domains)
> > To: tomcat-dev@jakarta.apache.org
> > X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
> > X-Priority: 3
> > X-MSMail-priority: Normal
> > 
> > 
> > Hi All,
> > 
> > I'm currently running multiple domains (2 specifically) on top of 
> > Apache/Tomcat.  It seems that when I hit both domains at 
> the same time 
> > (using 2 browser windows), I get a JSP compilation error 
> most (85%) of 
> > the time.
> > 
> > However, when I reload the page with no JSP code change, 
> it'll compile 
> > properly.  (Some of the time like 10-15%, it won't 
> recompile until I 
> > "touch" the file manually)
> > 
> > Note: It doesn't happen when I only access one domain.
> > 
> > PROBLEM SUMMARY:
> > When loading JSPs on multiple domains (hosts) simultaneously, a JSP 
> > compile error is generated.
> > 
> > SYSTEM COMPONENTS:
> > - Solaris 2.8
> > - JDK 1.4.0_01
> > - Tomcat 4.1.12
> > - Apache 1.3.20
> > 
> > SOLUTIONS TRIED (FAILED):
> > - Configured different workers for each domains (hosts) as 
> recommended 
> > in the tomcat mod_jk document.
> > - Downloaded the source of tomcat and recompiled everything on our 
> > environment.
> > 
> > Any help would be appreciated.
> > 
> > Thanks.
> > 
> > Best regards,
> > Joseph Kiok
> > 
> > 
> > 
> > 
> > --
> > To unsubscribe, e-mail:   
> <mailto:tomcat-dev-> unsubscribe@jakarta.apache.org>
> > For 
> additional commands, 
> e-mail: 
> > <mailto:tomcat-dev-help@jakarta.apache.org>
> > 
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:tomcat-dev-> unsubscribe@jakarta.apache.org>
> For 
> additional commands, 
> e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>
> 


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message