tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "iasandcb" <iasan...@hotmail.com>
Subject RE: [5.0] [VOTE] Removal of the LE distribution
Date Fri, 04 Oct 2002 00:56:19 GMT
You can find the JSP 2.0 requirement of J2SE 1.4 on
Page 18, "Relation To JSP 1.2"
Requiring the Java 2 platform, version 1.4 or later.
and
Page 20, "Related Documents"
Java 2 Platform, Standard Edition  http://java.sun.com/products/jdk/1.4

I have been very concerned with this requirement since JSP 2.0 spec was
initiated. I also feel that this decision is quite revolutionary, so the
new version deserves the number "2.0". 

I'll comment more to Craig's reply for summary.

-----Original Message-----
From: news [mailto:news@main.gmane.org] On Behalf Of Costin Manolache
Sent: Friday, October 04, 2002 3:31 AM
To: tomcat-dev@jakarta.apache.org
Subject: RE: [5.0] [VOTE] Removal of the LE distribution


iasandcb wrote:

> First all, I vote
> <ballot>
> +1 [ ] Yes, remove the LE distribution
> -1 [ ] No, keep both distributions
> </ballot>
> 
> Next, I'd like to make this clear: Tomcat 5 is based on JSP 2.0 spec, 
> which requires J2SE 1.4. Therefore Tomcat 5 also can't run without 
> J2SE 1.4 ideally. However, I found that the new catalina engine and 
> jasper 2 compiler for Tomcat 5 don't mandate so. Is J2SE 1.4(or later)

> necessary for Tomcat 5? Or does Tomcat 5 support J2SE 1.3(or earlier) 
> for backward compatibitity with disabled JSP 2 feature?
> My opinion on this issue is that Tomcat 5 should have J2SE 1.4 in
> compliance with JSP 2.0 spec basically.

What ???

Where did you find this info ? I read the JSP2.0 draft and didn't find
such thing. It would be just stupid - I don't know any 
other spec to require more than Java2 (i.e. JDK1.2+).

If the final spec is aproved and includes JDK1.4 requirements - then
there's nothing we can do, we'll have to stop supporting 1.3 in the
official tomcat distibution. But given that now the 2 specs are distinct
- and 
some people use only the servlet spec, I think the servlet engine and
connectors should remain JDK1.2+.

Costin 


> 
> IAS
> 
> -----Original Message-----
> From: Remy Maucherat [mailto:remm@apache.org]
> Sent: Friday, October 04, 2002 2:24 AM
> To: Tomcat Developers List
> Subject: [5.0] [VOTE] Removal of the LE distribution
> 
> 
> Hi all,
> 
> Before starting to release 5.0.x milestones, I would like to propose 
> having only one distribution for Tomcat 5.0.x, and standardize on what

> the LE distribution contains (so well, it's more the other 
> distribution which gets removed).
> 
> It has some advantages:
> - it is slightly smaller (less these days now that the XML parser has 
> to
> 
> be shipped again with Tomcat)
> - runs as-is on JDK 1.3 (because of the Xerces inclusion)
> - 99% Apache or Apache-style licence (the JDBC 2 standard extension is

> needed for JDK 1.3 DataSource support :-()
> - less user confusion
> 
> The main "problem" is that the user will need additional downloads for

> some of the more advanced features, and the package will also not run 
> on
> 
> JDK 1.2 as is (but from what I've seen, JDK 1.2 compatibility may not 
> be
> 
> a priority for developers).
> 
> <ballot>
> +1 [ ] Yes, remove the LE distribution
> -1 [ ] No, keep both distributions
> </ballot>
> 
> Remy
> 
> 
> --
> To unsubscribe, e-mail: 
> <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:tomcat-dev-help@jakarta.apache.org>

-- 
Costin



--
To unsubscribe, e-mail:
<mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message