tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amy Roh <amy...@apache.org>
Subject Re: JDK version support when coding patches
Date Tue, 10 Sep 2002 04:10:13 GMT
Christopher Todd wrote:
> I am working on a patch for Tomcat 4.x, and was wondering if there were any
> requirements for supporting older versions of the JDK.  Can I code up a
> patch that uses classes and/or methods only available in 1.4, or do I have
> to support 1.2?  Can I write two versions, one that uses 1.4 APIs, and one
> that supports 1.2+?

I believe you need to support *at least* 1.3.  So I don't think it's a 
good idea to use classes or methods only available in 1.4.

Amy

> 
> Chris
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>
> 




--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message