tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: Cannot load /usr/lib/apache/mod_webapp.so
Date Tue, 03 Sep 2002 11:29:55 GMT
Jan Bromberger wrote:
>>>Syntax error on line 249 of /etc/httpd/httpd.conf:
>>>Cannot load /usr/lib/apache/mod_webapp.so into server: libapr-0.so.0:
>>>cannot load shared object file: No such file or directory
>>>
>>>I built just today from CVS - both the webapp connector and APR.
>>>My system is SuSE Linux running on a PC.
>>
>>That is good for webapp but not for APR you should used the released APR
>>See http://www.apache.org/dist/apr/
> 
> I followed README.txt to load it from CVS
> 
> I get the same error with current (12:50 GMT+1) CVS from webapp and APR 0.9.
> 
> 
>>>What can I further tell you to help you helping me?
>>
>>The output of ldd /usr/lib/apache/mod_webapp.so
> 
>         libm.so.6 => /lib/libm.so.6 (0x40013000)
>         libcrypt.so.1 => /lib/libcrypt.so.1 (0x40032000)
>         libnsl.so.1 => /lib/libnsl.so.1 (0x40061000)
>         libdl.so.2 => /lib/libdl.so.2 (0x40077000)
>         libapr-0.so.0 => not found
>         libc.so.6 => /lib/libc.so.6 (0x4007b000)
>         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
> 
> After I placed libapr-0.so.0 into /usr/lib I got
> 
> Syntax error on line 249 of /etc/httpd/httpd.conf:
> Cannot load /usr/lib/apache/mod_webapp.so into server:
> /usr/lib/libapr-0.so.0: undefined symbol: pthread_create

You have a thread APR mod_webapp+apache-1.3 needs a non-threaded one.

How have you made your APR?

> 
> And I do NOT know what I was doing.
> 
> Cheers,
> Jan
> 
> 




--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message