tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12110] - Database connection does not work
Date Wed, 04 Sep 2002 17:00:44 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12110>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12110

Database connection does not work

patrick.luby@sun.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |INVALID



------- Additional Comments From patrick.luby@sun.com  2002-09-04 17:00 -------
The problem is due to a syntax error in your <ResourceParams> element. The
following snippet:

      <parameter>
        <name>user</name>
        <value>PUBLIC</value>
      </parameter>

should be:

      <parameter>
        <name>username</name>
        <value>PUBLIC</value>
      </parameter>

DBCP was using your Windows user name to connect to the database because when
the "username" parameter is missing (the "user" parameter that you used is
ignored), DBCP will attempt to use the value of the "user.name" system property.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message