tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12263] New: - response.sendRedirect won't send to Tomcat SSL
Date Tue, 03 Sep 2002 15:35:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12263>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12263

response.sendRedirect won't send to Tomcat SSL

           Summary: response.sendRedirect won't send to Tomcat SSL
           Product: Tomcat 4
           Version: 4.0.4 Final
          Platform: Sun
        OS/Version: Other
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Connector:Webapp
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: thad@mindwrap.com


This *may* be a duplicate of #1663 but I'm not sure.

We are attempting to deploy a JSP/servlet application on a Stronghold server on
Solaris 7 with Tomcat 4.0.4 and mod_webapp.  The server version is

#./httpd -v
Server version: Stronghold/3.0 Apache/1.3.12 C2NetEU/3011 (Unix)
Server built:   Jun  1 2000 15:25:28

Problem:  When a servlet calls response.sendRedirect(<url>) that was called with
https, we get a 400 (bad request) error.  Instead of sending to
https://server_name/application/jsp, it goes to
http://server_name:443/application/jsp ("You are speaking plain HTTP to an
SSL-enabled server port.).  <jsp:forward> works fine.

Ideas?  Work arounds?

(If you want a URL for this, contact me or szimmer@mindwrap.com.)

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message