tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12253] New: - Catalina fails to set proper charset
Date Tue, 03 Sep 2002 11:32:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12253>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12253

Catalina fails to set proper charset

           Summary: Catalina fails to set proper charset
           Product: Tomcat 4
           Version: 4.1.7
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: cs98011@icsd.aegean.gr


I have implemented a filter that changes the charset to a user specified one
before a request reaches a servlet. The problem is that no other charset is
working except the default (ISO-8859-7). I have tried to look in the source
code. There seems to be an issue in the catalina/utils/URL.java in URLDecode
functions. The default java.net.url class correctly decodes the form data, while
the custom implementation in Tomcat does not. I 'vw also noticed that it does
not work in UTF8 charsets.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message