tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12231] New: - CGI scripts in Rexx receive no input in POST
Date Mon, 02 Sep 2002 15:18:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12231>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12231

CGI scripts in Rexx receive no input in POST

           Summary: CGI scripts in Rexx receive no input in POST
           Product: Tomcat 4
           Version: 4.0.4 Final
          Platform: PC
        OS/Version: OS/2
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Servlets:CGI
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: sehh@altered.com


CGI scripts do not receive any input from POST requests.

GET requets work fine, since the environment variable QUERY_STRING is set.

POST requests do not work, since the output from the server never reaches the
Rexx script.

I'm using charin(,,Length), where Length is equal to the size reported by
CONTENT_LENGTH. charin returns an empty string since it never receives anything
from Tomcat, even though the CONTENT_LENGTH is set to >0.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message