tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Oxley <d...@staffplanner.co.uk>
Subject RE: Bug in WebappClassLoader
Date Wed, 28 Aug 2002 12:23:04 GMT
Remy,

Never mind. Have just seen your commits! Easier than my solution! :) Thanks
for getting it into 4.1.

Dave.

> -----Original Message-----
> From: David Oxley
> Sent: 28 August 2002 13:05
> To: 'Tomcat Developers List'
> Subject: RE: Bug in WebappClassLoader
> 
> Remy,
> 
> Here's the new patch. Has been tested and allows me to now use RMI (after
> calling addRepository). Also, I have implemented the URLEncoder from
> catalina.utils area. See what you think.
> 
> Dave.
> 
> > -----Original Message-----
> > From: David Oxley [mailto:dave@staffplanner.co.uk]
> > Sent: 28 August 2002 09:48
> > To: 'Tomcat Developers List'
> > Subject: RE: Bug in WebappClassLoader
> >
> > Remy,
> >
> > Ok. I know I haven't tested it yet! :( I haven't gotten 4.1 to compile
> > from
> > CVS yet. Can we get the patch for bug 1 committed though. This would
> allow
> > people to use RMI (I think) by adding the repository http://server/app
> to
> > the ClassLoader. Were you thinking of trying to make 4.1.10 the stable
> > release? If not couldn't we slip it in before.
> >
> > Dave.
> >
> > > -----Original Message-----
> > > From: Remy Maucherat [mailto:remm@apache.org]
> > > Sent: 28 August 2002 08:19
> > > To: Tomcat Developers List
> > > Subject: Re: Bug in WebappClassLoader
> > >
> > > David Oxley wrote:
> > > > All,
> > > >
> > > >
> > > >
> > > > There is a couple of bugs in WebappClassLoader.
> > > >
> > > > 1. On line 953 there is a call to findClassInternal which could
> throw
> > a
> > > > ClassNotFoundException that gets caught on line 979. This means that
> > > > lines 963 through 973 will never get executed. i.e. Repositories
> added
> > > > with the method AddRepository will not get searched.
> > >
> > > That one is a minor bug, so it will not be fixed until after the first
> > > TC 4.1 stable release.
> > >
> > > > 2. Also URL's returned from getURL are not encoded.
> > >
> > > Your fix is wrong (all the URL special characters would get encoded,
> > > including ':', '/' and others).
> > >
> > > > I have submitted a patch for these two problems, but I have not got
> > > > tomcat 4 to compile yet so haven't tested the patch.
> > >
> > > Please try to test patches a little bit before, it saves a few round
> > > trips.
> > >
> > > > Comments or flames welcome. :)
> > >
> > > Better luck next time then ;-)
> > >
> > > Remy
> > >
> > >
> > > --
> > > To unsubscribe, e-mail:   <mailto:tomcat-dev-
> > > unsubscribe@jakarta.apache.org>
> > > For additional commands, e-mail: <mailto:tomcat-dev-
> > > help@jakarta.apache.org>
> >
> > --
> > To unsubscribe, e-mail:   <mailto:tomcat-dev-
> > unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail: <mailto:tomcat-dev-
> > help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message