tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject New Developer, error compiling tomcat 4.1.7
Date Thu, 08 Aug 2002 15:06:15 GMT
I am getting the following error when compiling tomcat 4.1.7:

[javac] Compiling 28 source files to /home/agandhi/jakarta-tomcat-4.1.7-src/jasper/build/shared/classes
[javac] /home/agandhi/jakarta-tomcat-4.1.7-src/jasper/src/share/org/apache/j
asper/compiler/ cannot resolve symbol
[javac] symbol : method setCompiler (java.lang.String)
[javac] location: class
[javac] javac.setCompiler(options.getCompiler());
[javac] ^
[javac] /home/agandhi/jakarta-tomcat-4.1.7-src/jasper/src/share/org/apache/j
asper/ cannot resolve symbol
[javac] symbol : method getClasspath ()
[javac] location: class
[javac] ((
[javac] ^
[javac] Note: /home/agandhi/jakarta-tomcat-4.1.7-src/jasper/src/share/org/ap
ache/jasper/servlet/ uses or overrides a deprecated API.
[javac] Note: Recompile with -deprecation for details.
[javac] 2 errors

I am using ant 1.5 as required for this version of tomcat.

Although even after downloading binary and src versions of ant 1.5 whenever I do: /usr/local/jakarta-ant-1.5/bin/ant
-version it gives this:
Ant version 1.4.1 compiled on October 11 2001

Can anybody please help me with this. I am trying this for a couple of days now.

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message