tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12049] - jsp:include does not resolve symlinked directory
Date Tue, 27 Aug 2002 22:34:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12049>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12049

jsp:include does not resolve symlinked directory





------- Additional Comments From xliu@capitalthinking.com  2002-08-27 22:34 -------

> I posted exactly the same question before and got no
> response. jsp:include seems not working with symlinked
> directory.
>
> It works on 4.0 version, but stops working on 4.1 version.

It really works fine with TC4.0.4, and everything works: linked directories, 
linked files, static and dinamic includes of linked files

With TC 4.1.9 it does not work but if I make top level linked directory in my 
webapps folder, that works fine assuming that this directory itself does not 
have symlinks inside of it
As soon as it gets symlinkes inside, those don't not work. For example, the 
context http://localhost:8080/german/, where german is a symbolic link to the 
directory /opt/tomcat4.0.4/webapps/german in the webapps folder of TC 4.1.9 
(/opt/tocmat4.1.9/webapps), shows next listing


Filename                         Size           Last Modified
   
AddNewWord.jsp                   0.2 kb         Fri, 23 Aug 2002 22:57:08 GMT
   
OracleDataSource.jsp             1.8 kb         Thu, 22 Aug 2002 05:53:38 GMT
   
admin/                                          null
   
include.jsp                      0.1 kb         Tue, 27 Aug 2002 06:19:25 GMT
   
link.html/                                      null
   
link.jsp/                                       null

Everywhere where there is null we have symbolic links: admin - folder, other 
files and they don't work. But usual jsp in the symlinked folder german works 
fine. Although include.jsp does not work (shows empty page) because it has 
inside only include statements for above mentioned symlinks

> Is it a tomcat bug or coyote bug?

Actually I tried a quick test, commented Coyote connector 
(org.apache.coyote.tomcat4.CoyoteConnector) with port 8080 and uncommented 
the HttpConnector(org.apache.catalina.connector.http.HttpConnector), for the 
last one I changed port 8083 to 8080. Restart Tomcat, and nothing was 
changed. That all I did not go deeper

ilis

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message