tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 11846] - Class loader problem
Date Tue, 20 Aug 2002 20:53:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11846>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11846

Class loader problem





------- Additional Comments From james.shiell002@msd.govt.nz  2002-08-20 20:53 -------
We are experiencing a very similar problem with our project.

We have a Web App which is accessing EJBs running on a WebLogic 6.1
installation. Thus in WEB-INF/lib we have weblogic.jar. This works correctly
using Tomcat 4.0.1. However, if we upgrade Tomcat to either 4.0.3 (as supplied
with JBuilder 7) or Tomcat 4.0.4 when we receive:

java.lang.NoClassDefFoundError: javax/ejb/EJBException
	at java.lang.ClassLoader.defineClass0(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:486)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:111)
	at
org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:1643)
	at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:937)
	at
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1372)
	at
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1254)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:313)
(you get the idea...)

I haven't managed to get manager approval for time to produce a test case
unfortunately :-( Will keep trying.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message