tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Osamu Hashimoto" <...@yha.att.ne.jp>
Subject Re: pageEncoding for Shift_JIS doesn't work by using Apache Tomcat/4.1.8-LE-jdk14
Date Tue, 13 Aug 2002 10:02:43 GMT

Hello again, David.

Thank you for consideration for pageEncoding issue.

At this point, I am trying 4.1.8 too.

I also found JSP's result view by browser written like
shown below : 

<%@ page pageEncoding="Shift_JIS" %>

together with

<%@ page contentType="text/html; charset=Shift_JIS" %>

or

<%@ page pageEncoding="Shift_JIS" 
              contentType="text/html; charset=Shift_JIS"
%>

works fine for written by Shift_JIS charset.

However pageEncoding element without contentType element
like below

<%@ page pageEncoding="Shift_JIS" %>

does not work for written JSP files by Shift_JIS, and will be
garbage characters.


This is simply a problem right now.


----- Original Message ----- 
From: "David Shanahan" <david.shanahan@biosjp.com>


> 
> I just tried 4.1.8 and it seems to work fine. I tried
> 
> <%@ page pageEncoding="Shift_JIS" %>
>  
> AND
> 
> <%@ page contentType="text/html; charset=Shift_JIS" %>
> 
> and they both worked fine.
> 
> By the way I am using the 4.1.8 with the IBM 1.3 JDK on a Linux 
> machine. Also as you should be able to tell by the above examples,
> I am using the original (not the new xml) syntax for the jsp files.
> 
> 



   Osamu Hashimoto

   osm@yha.att.ne.jp





--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message