tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew T. Veliath" <andre...@usa.net>
Subject [PATCH] Re: mod_webapp returns improper HTTP header (Apache 2 + Tomcat 4)
Date Thu, 04 Jul 2002 22:24:37 GMT
 .........----------------==================----
..--==-  Thu, 4 Jul 2002 14:18:07 -0500,
..--==-  Ten-Hung Chu (TC) discussed:

 TC)  I am using Apache 2.0.39 with Tomcat 4.0.4 through mod_webapp (1.2.0-dev).
 TC)  The connection works fine except getting to the welcome-file on tomcat. I
 TC)  can request the file directly like /examples/jsp/index.html but requesting
 TC)  /examples/jsp/ results in a 302 temporary moved page. Looking at the
 TC)  response headers I found that mod_webapp returns an incorrect header

Hi,

I had made the following change to get the webapp connector in 4.0.4
release working properly with Apache 2.0.39.

--- orig/jakarta-tomcat-connectors-4.0.4-src/webapp/apache-2.0/mod_webapp.c	Mon Jun 10 23:48:08
2002
+++ jakarta-tomcat-connectors-4.0.4-src/webapp/apache-2.0/mod_webapp.c	Sat Jun 22 12:25:05
2002
@@ -305,7 +305,7 @@
     request_rec *req=(request_rec *)r->data;
 
     if (status !=NULL && status[0]!='\0')
-        req->status_line=apr_pstrdup(req->pool,status);
+	req->status_line=apr_psprintf(req->pool,"%d %s",req->status,status);
 }

Regards, 
Andrew

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message