tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Conrad" <andrewcon...@msn.com>
Subject RE: [PATCH] ant download, build.xml, build.properties.sample and BUILDING.txt
Date Mon, 15 Jul 2002 02:34:36 GMT
I ran into the same problem  (NullPointerException on xml to html
transformation)  The Java XML Pack (summer 02) contains Xalan 2.2 or 2.3
(don't remember) but that version of Xalan has a known transformation
bug. Download Xalan 2.4.D1 from http://xml.apache.org/xalan-j/index.html
and drop the xalan.jar from that location into your ant directory.

- Andrew

-----Original Message-----
From: Fredrik Viklund [mailto:fredrikv@biochem.kth.se]
Sent: Sunday, July 14, 2002 6:40 PM
To: tomcat-dev@jakarta.apache.org
Subject: [PATCH] ant download, build.xml, build.properties.sample and
BUILDING.txt


I recently started out trying to build Tomcat 4.1 from sources and found
that the process was quite painful. While doing my homework, I found a
few bulid problems and that BUILDING.txt, build.xml and
build.properties.sample could be improved on a few points:

(Patches are sent separately. Sorry if this is a bit long.)



(1) I can't get building with JDK 1.3.1 to work. It quits on error:
    [style] Processing
C:\jakarta-test\jakarta-tomcat-4.1.7-src\webapps\tomcat-
docs\config\globalresources.xml to C:\jakarta-test\jakarta-tomcat-4.1.7-

src\webap ps\build\tomcat-docs\config\globalresources.html

    [style] : Fatal Error! java.lang.NullPointerException Cause:
java.lang.NullPointerException

    [style] Failed to process C:\jakarta-test\jakarta-tomcat-4.1.7-
src\webapps\tomcat-docs\config\globalresources.xml

BUILD FAILED
file:C:/jakarta-test/jakarta-tomcat-4.1.7-src/webapps/tomcat-docs/build.
xml:112:

Fatal error during transformation



(2) I can't build with J2SDK 1.4.0 without JNDI, LDAP, JDBC Optional API
and
    JSSE.

The only reason I include these problems here is that I suspect that
they are caused by me not knowing how to set these things up. I have
read the docs and tried hard and I guess that if I can't get it working,
the chances are that other people can't either. If there are any
"secret" building tricks, they should be documented in the BUILDING.txt,
but obviously, I can't do it... (If the tricks aren't secret but
obvious, they should be documented anyway as
"gotchas".)



(3) Patches to make "ant download" work

With the changes below "ant download dist" works on my system. (There
are still errors warnings from javadoc, but that might be normal, I
can't tell...)



build.xml
=========
* Changed default value for servlet.home to so it corresponds with
  build.properties.sample

* In the target "download"
  - Gave it a description so it shows up on "ant -projecthelp"
  - ant dist breaks for me when commons-digester is the downloaded
version 1.2.
    Version 1.1.1 and nightly works, so I changed commons-digester to
use cvs
    for download. Move it below commons-logging as it is needed for
building.
  - Copying the docs for servletapi after cvsbuild makes it work on
download.
  - Decommented tyrex download
  - Added a new method target "downloadcvs" to download with CVS
whithout building.
  - Download the current source versions of Jakarta-Tomcat-Connectors
and Jasper
    using downloadcvs.


build.properties.sample
=======================
* Connectors and Jasper got ${.loc} properties to enable automatic
download

* Commons-Digester downloads via CVS (see above)

* Updated versions to
  - JAF 1.0.2  (from 1.0.1)
  - JSSE 1.0.3 (from 1.0.2)
  - JavaMail 1.3   (from 1.3)


BUILDING.txt
============
The text had become complex and very hard to read and needed a facelift.

I changed the order of some elements (e.g. if a section is optional, it
should say that in the beginning of that section) and removed paragraphs
that were repeated for each package. I also added some notes on using
"ant download" and made the bulleting style more consistent.

The versions for some of the downloaded packages have increased and were
updated to JAF 1.0.2, JSSE 1.0.3 and JavaMail 1.3.

Over all, I did not add much new content but I think the readability
increased quite a bit.



(4) Questions still without an answer (things that I didn't dare to
change.)

* Are there any good reasons why is JDK 1.3.1 recommended or is it the
remains
  from when it was also possible to build with 1.3.0?

* Is the JNDI package needed at all? It is said to be optional with JDK
1.3+,
  which is also the minimum version required for building.





--
To unsubscribe, e-mail:
<mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message