tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cost...@covalent.net
Subject RE: Jasper2: serious problem with tag declarations
Date Wed, 19 Jun 2002 22:43:32 GMT
I think I found something - it is probably related with the changes
in JspContext, since previous versions seem to work.

I'll try to debug it further.

Costin

On Wed, 19 Jun 2002 costinm@covalent.net wrote:

> More info:
> 
> The page is:
> 
>  <%@ taglib uri="/WEB-INF/struts-logic.tld" prefix="logic" %>
> 
>   <logic:iterate id="id1" name="name1" property="prop1">
>     <logic:iterate id="id2" name="name2" property="prop2">
>       Foo
>     </logic:iterate>
>   </logic:iterate>
> 
> I get:
> 
> a$jsp.java:75:25:75:25: Error: No entity named "id2" was found in this 
> environment.
> 
> And the generated code is:
>           .....
>           /* ----  logic:iterate ---- */
>           java.lang.Object _jspx_id2_1;
>           _jspx_id2_1 = id2;
>           org.apache.struts.taglib.logic.IterateTag 
> _jspx_th_logic_iterate_1 = (org.apache.struts.taglib.logic.IterateTag) 
> _jspx_tagPool_logic_iterate_property_name_id.get(org.apache.struts.taglib.logic.IterateTag.class);
> 
>          ....
> 
> No 'id2' is ever declared.
> 
> So it only happens if you have nested <logic:iterate>.
> 
> Am I doing something wrong here ? Do we run any tests with nested tags ? 
> 
> 
> Costin
> 
> 
> --
> To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>
> 
> 


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message