tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10328] New: - Rpm doesn't install with correct ownership/permissions
Date Fri, 28 Jun 2002 16:31:14 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10328>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10328

Rpm doesn't install with correct ownership/permissions

           Summary: Rpm doesn't install with correct ownership/permissions
           Product: Tomcat 4
           Version: 4.0.4 Final
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Installable Packages
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: richard@dcs.bbk.ac.uk


Tomcat needs to run as the user tomcat4.
When run as root, the rpm creates an account for
this user.

It then assigns all the files to belong to root,
hence tomcat refuses to save any files to the
webapps directory and no applications can be
deployed.

chown -R tomcat4:tomcat4 fixes this, but the rpm
should install it correctly.

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message