tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9650] New: - mod_webapp causes Apache to go into infinite loop if application is deployed outside of tomcat default webapp location
Date Wed, 05 Jun 2002 21:08:29 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9650>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9650

mod_webapp causes Apache to go into infinite loop if application is deployed outside of tomcat
default webapp location

           Summary: mod_webapp causes Apache to go into infinite loop if
                    application is deployed outside of tomcat default webapp
                    location
           Product: Tomcat 4
           Version: 4.0.3 Final
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Connector:Webapp
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: tina.armstrong@sas.com


I have Tomcat 4.0.3 and Apache 1.3.2
if I have in my httpd.conf the following:

 WebAppConnection warpConnection warp  D4011.na.sas.com:8008
 WebAppDeploy examples  warpConnection  /examples
 WebAppInfo /webapp-info

I can access the examples application fine from running Tomcat standalone and 
also running it connected to Apache. 
However, I have numerous applications deployed in different locations, that are 
*not* under the Tomcat default webapp directory, and when I try to add these 
with WebAppDeploy directives, it causes Apache to go into some kind of infinite 
loop, filling up the error.log by the multitudes!

I have seen numerous folks with this problem, but everyone that I have spoken 
to says that they have not reported the problem, that instead, they have done
something other than to use mod_webapp. 

Can this be looked into?

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message