tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cost...@covalent.net>
Subject Re: [JK2] The IIS Connector is ( more or less ) working!!
Date Fri, 10 May 2002 23:38:16 GMT
On Sat, 11 May 2002, Ignacio J. Ortega wrote:

> Costin, Can you summarize a bit, what i need to build and use to have
> tc33 & tc40 working with JNI?

Not much - you do need APR, you should use the version that is bundled 
with  Apache2.0 ( the DLL and includes ). 

Then compile with HAVE_JNI enabled, check the config of [vm], [worker.jni]
and [channel.jni].

The [vm] objects deals with loading the VM - it needs classpath and all 
the params.

[worker.jni] will execute a class ( calling main() ), you can include as 
many as you want ( but of course you need TomcatStarter if you want to run 
a version of tomcat ). 

[channel.jni] will forward the requests. 

You'll probably need to fix AprImpl a bit, right now there is a mod_jk.so
hardcoded and probably few other things need to change to get it to work 
on windows. If you can wait till next week, I can help with this part.

One important piece ( not related directly with jni ) is the jk_shm object
and Shm on java side. Those will play an important role, and we need to 
get them working on windows. Shm is not a big problem, if we get into 
problems we can use JDK1.4's nio - i.e. no JNI is needed.



Costin





--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message