tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9351] New: - IPv6 HTTP/1.1 requests not working
Date Thu, 23 May 2002 14:43:39 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9351>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9351

IPv6 HTTP/1.1 requests not working

           Summary: IPv6 HTTP/1.1 requests not working
           Product: Tomcat 4
           Version: 4.0.3 Final
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: jserna@tid.es


The problem is in org.apache.catalina.connector.http.HttpProcessor the parsing 
of the Host header assumes that its format is:

<host_name>[:port]

where host_name mustn't contain any ':' character.

But with IPv6 addresses (RFC 2736 - Format for literal IPv6 addresses in URL), 
a valid address could be:

[3ffe:3328:6:3::2]:80

and so the code:

---

} else if (header.equals(DefaultHeaders.HOST_NAME)) {
                  int n = value.indexOf(':');

----

which assumes ':' only as port separator is not working.

Additional parsing must be added to this class in order to take into account 
IPv6 Addresses.

Jorge Serna

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message