tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cost...@covalent.net>
Subject Re: [NITPICK] didn't see this one coming...
Date Mon, 29 Apr 2002 14:54:09 GMT
On Mon, 29 Apr 2002, Remy Maucherat wrote:

> > However I do think we should somehow document better what's
> > happening - many people have the strange impression that
> > webapp is going to replace jk.
> 
> I'd like to find a way to indicate that the two preferred connectors are:
> - Coyote HTTP/1.1
> - Coyote JK 2 (AJP with mod_jk, JNI)

And to clearly indicate that for whatever OS Pier is using and Apache2,
users can also use mod_webapp.

( for 3.3 we do the same for mod_jserv and Apache1.3 ).

Note that mod_jk2 is not and will not be ready for 4.1, and JNI 
doesn't work with 4.x in mod_jk1. 

PROPOSAL:
Rename Coyote-jk2 -> coyote-jk. Or just drop the coyote-jk and coyote-http
 from documentations, no need to confuse users. 

There is the "coyote" connector, it supports http/1.1 and mod_jk. 

The current stable release of mod_jk is mod_jk1.5, the 
alpha/beta release is mod_jk2. 

Costin





--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message