tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "GOMEZ Henri" <hgo...@slib.fr>
Subject RE: Apache 2.0.35 and mod_jk 1.2.0
Date Mon, 08 Apr 2002 08:12:30 GMT
I'll build rpm for Apache 2.0.35 and see if I've 
got the same problem

-
Henri Gomez                 ___[_]____
EMAIL : hgomez@slib.fr        (. .)                     
PGP KEY : 697ECEDD    ...oOOo..(_)..oOOo...
PGP Fingerprint : 9DF8 1EA8 ED53 2F39 DC9B 904A 364F 80E6 



>-----Original Message-----
>From: Bojan Smojver [mailto:bojan@binarix.com]
>Sent: Monday, April 08, 2002 7:14 AM
>To: Tomcat Dev List
>Subject: Apache 2.0.35 and mod_jk 1.2.0
>
>
>I'm playing with Apache 2.0.35 and mod_jk 1.2.0 (from CVS) and I've
>encountered some weird behaviour in regards to DirectoryIndex directive
>of Apache. It seems that all *.jsp/*.vm (and whatever other extensions
>are mapped to Tomcat through mod_jk) have stopped working as default
>indexes for directories. This is what happens if one request the file
>/index.vm is requested:
>
>---------------------------------------------
>[Mon Apr 08 14:49:01 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_t::map_uri_to_worker
>[Mon Apr 08 14:49:01 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '/index.vm'
>[Mon Apr 08 14:49:01 2002]  [jk_uri_worker_map.c (529)]:
>jk_uri_worker_map_t::map_uri_to_worker, Found a suffix match ajp13 ->
>*.vm
>[Mon Apr 08 14:49:01 2002]  [mod_jk.c (1223)]: Into handler
>r->proxyreq=0 r->handler=jakarta-servlet r->notes=136294352 
>worker=ajp13
>[Mon Apr 08 14:49:01 2002]  [jk_worker.c (132)]: Into
>wc_get_worker_for_name ajp13
>[Mon Apr 08 14:49:01 2002]  [jk_worker.c (136)]: 
>wc_get_worker_for_name,
>done  found a worker
>[Mon Apr 08 14:49:01 2002]  [mod_jk.c (437)]: agsp=80
>agsn=www.makita.dev hostn=www.makita.dev shostn=www.makita.dev
>cbsport=80 sport=0 
>[Mon Apr 08 14:49:01 2002]  [jk_ajp_common.c (1352)]: Into
>jk_worker_t::get_endpoint
>---------------------------------------------
>
>which is all nice and dandy. However, when the / is requested, it looks
>a bit different:
>
>---------------------------------------------
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_
>t::map_uri_to_worker
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '
>/'
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (570)]:
>jk_uri_worker_map_t::ma
>p_uri_to_worker, done without a match
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_
>t::map_uri_to_worker
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '
>/index.shtml'
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (570)]:
>jk_uri_worker_map_t::ma
>p_uri_to_worker, done without a match
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_
>t::map_uri_to_worker
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '
>/index.html'
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (570)]:
>jk_uri_worker_map_t::ma
>p_uri_to_worker, done without a match
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_
>t::map_uri_to_worker
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '
>/index.jsp'
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (529)]:
>jk_uri_worker_map_t::map_uri_to_worker, Found a suffix match ajp13 ->
>*.jsp
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_
>t::map_uri_to_worker
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '
>/index.vm'
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (529)]:
>jk_uri_worker_map_t::map_uri_to_worker, Found a suffix match ajp13 ->
>*.vm
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_
>t::map_uri_to_worker
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '
>/index.php'
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (570)]:
>jk_uri_worker_map_t::ma
>p_uri_to_worker, done without a match
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (447)]: Into
>jk_uri_worker_map_
>t::map_uri_to_worker
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (464)]: Attempting to
>map URI '
>/index.php3'
>[Mon Apr 08 14:49:40 2002]  [jk_uri_worker_map.c (570)]:
>jk_uri_worker_map_t::ma
>p_uri_to_worker, done without a match
>---------------------------------------------
>
>which all comes from here (defined in server config section of Apache
>2.0):
>
>---------------------------------------------
><IfModule mod_dir.c>
>    DirectoryIndex index.shtml index.html index.jsp index.vm index.php
>index.php
></IfModule>
>---------------------------------------------
>
>However, /index.vm (which exists and works fine when called explicity),
>never gets called by mod_jk although the match for it is found 
>(i.e. the
>*.vm match). I must be doing something silly...
>
>Apache is statically linked, if that makes any difference.
>
>Bojan
>
>
>--
>To unsubscribe, e-mail:   
><mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
>For 
>additional commands, e-mail: 
><mailto:tomcat-dev-help@jakarta.apache.org>
>
>

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message