tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Punky Tse <punky...@yahoo.com>
Subject RE: Error running Apache 2.0 with mod_webapp.so or mod_jk-01.so binaries
Date Fri, 12 Apr 2002 18:25:19 GMT
> 
> Thanks for your quick response.  I'm glad to hear you got it running.  That
> certainly gives hope!
>
You are welcome. ;-) 
 
> I've tried mod_webapp and mod_jk and get the same error for each.  I
> downloaded:
> -  jakarta-tomcat-4.0.3.tar
> -  mod_webapp.so (downloaded the binary)
> 
I build from source.  Try download the source tar ball and follow the
instruction in README.txt and INSTALL.txt.

> Tomcat seems to work fine on its own.  Apache seems to work fine on its
> own.
> My problem is getting mod_webapp to link the two.  I get the error below as
> soon as I include the LoadModule line in my httpd.conf:
> 
> [root@bicaweb_dev webapps]# $APACHE_HOME/bin/apachectl start
> Syntax error on line 220 of /opt/apache2/conf/httpd.conf:
> Cannot load /opt/apache2/modules/mod_webapp.so into server:
> /opt/apache2/modules
> /mod_webapp.so: undefined symbol: ap_table_get
> /opt/apache2/bin/apachectl start: httpd could not be started
> 
Hum.. seems like the pre-build binary using the older version of APR?  I
don't  know, my recent copy of 2.0.36-dev also does not have ap_table_get()
function:

nm httpd | grep ap_table_get

howerver, I found apr_table_get symbol in httpd instead.  Anybody here in
this list know if there had been such API change in APR?

> Again, thanks very much for any suggestions you might have.
> 
> Ray Peck
> Building Industry Credit Association
> 
Punky



__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/

--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message