tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Punky Tse" <punky...@yahoo.com>
Subject Re: Building modapp for Tomcat4.0 and apache1_3.23
Date Thu, 11 Apr 2002 09:06:52 GMT
>
> The problem described is a compilation problem and isn't related to to the
make install.  I had this problem when I tried to compile the source after
downloading it a while ago.  The problem is caused by the constants TYPE_...
not being defined anywhere in the source.  To solve this problem I took at
look at the java warp source to determine what the constants should be and
then added them into pr_warp.h file as follows:
>
> #define TYPE_ERROR 0x00
> #define TYPE_DISCONNECT 0xfe
> ....

I recalled that lib/pr_warp_defs.h was failed to be generated when
Constant.java had been moved.

See the diff:
http://cvs.apache.org/viewcvs/jakarta-tomcat-connectors/webapp/lib/Makefile.
in.diff?r1=1.21&r2=1.22&diff_format=h

>
> As I mentioned I downloaded my source a while ago and I haven't checked
against the latest source.  If the problem is still there then I think this
might be a broken mainline.
>

By checking the cvs history, it only fails if you downloaded mod_webapp
source between 23-30 Jan 2002.

> Simon.
>
>

Punky


_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message