tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: Absolute URI problem
Date Tue, 02 Apr 2002 20:30:34 GMT

----- Original Message -----
From: "Remy Maucherat" <remm@apache.org>
To: "Tomcat Developers List" <tomcat-dev@jakarta.apache.org>
Sent: Tuesday, April 02, 2002 11:51 AM
Subject: Re: Absolute URI problem


> > 3.3.1 can't have such a problem, since it isn't a HTTP/1.1 server. :)
>
> Yes indeed ;-)
>
> > To have a HTTP/1.1 server you need to download the Coyote Beta from
> >
>
http://jakarta.apache.org/builds/jakarta-tomcat-connectors/coyote/release/v1
> > .0-b4/ Coyote can handle absolute URIs AFAIK.
>
> The old HTTP/1.1 connector was also working with abs URLs AFAIK.
> It wasn't supported in some of the earlier Coyote releases.
>
> I plan to make a new Coyote release once I add the support for
> getRemoteHost/Addr in the TC 4 adapter. Is it ok with you ?
>

Fine with me.  I've got a couple of enhancements in tomcat3 pending (e.g.
doing the RemoteHost lookup per-connection instead of per-request), but they
aren't urgent.  And it will probably be a few days before I find the time
for them.
> Remy
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-dev-help@jakarta.apache.org>


Mime
View raw message